Errors at install app-ui


#1

Hola,
I get the following when putting “npm install” in app-ui:
/app-ui# npm install
npm WARN optional Skipping failed optional dependency /chokidar/fsevents:
npm WARN notsup Not compatible with your operating system or architecture: fsevents@1.1.2
npm WARN silhouette-play-react-seed@4.0.0 No repository field.
npm WARN silhouette-play-react-seed@4.0.0 license should be a valid SPDX license expression


#2

Hi,

These are only warnings and should not affect the install process.

Best regards,
Christian


#3

Thanks, Now, I try to install, but the following comes out, using “sbt run”:
0 info it worked if it ends with ok
1 verbose cli [ ‘/usr/bin/nodejs’,
1 verbose cli ‘/usr/bin/npm’,
1 verbose cli ‘–loglevel verbose’,
1 verbose cli ‘run’,
1 verbose cli ‘start’ ]
2 info using npm@3.5.2
3 info using node@v4.7.2
4 verbose run-script [ ‘prestart’, ‘start’, ‘poststart’ ]
5 info lifecycle silhouette-play-react-seed@4.0.0~prestart: silhouette-play-react-seed@4.0.0
6 silly lifecycle silhouette-play-react-seed@4.0.0~prestart: no script for prestart, continuing
7 info lifecycle silhouette-play-react-seed@4.0.0~start: silhouette-play-react-seed@4.0.0
8 verbose lifecycle silhouette-play-react-seed@4.0.0~start: unsafe-perm in lifecycle true
9 verbose lifecycle silhouette-play-react-seed@4.0.0~start: PATH: /usr/share/npm/bin/node-gyp-bin:/var/www/html/mejorcambio/app-ui/node_modules/.bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/snap/bin
10 verbose lifecycle silhouette-play-react-seed@4.0.0~start: CWD: /var/www/html/mejorcambio/app-ui
11 silly lifecycle silhouette-play-react-seed@4.0.0~start: Args: [ ‘-c’, ‘neutrino start’ ]
12 silly lifecycle silhouette-play-react-seed@4.0.0~start: Returned: code: 1 signal: null
13 info lifecycle silhouette-play-react-seed@4.0.0~start: Failed to exec start script
14 verbose stack Error: silhouette-play-react-seed@4.0.0 start: neutrino start
14 verbose stack Exit status 1
14 verbose stack at EventEmitter. (/usr/share/npm/lib/utils/lifecycle.js:232:16)
14 verbose stack at emitTwo (events.js:87:13)
14 verbose stack at EventEmitter.emit (events.js:172:7)
14 verbose stack at ChildProcess. (/usr/share/npm/lib/utils/spawn.js:24:14)
14 verbose stack at emitTwo (events.js:87:13)
14 verbose stack at ChildProcess.emit (events.js:172:7)
14 verbose stack at maybeClose (internal/child_process.js:854:16)
14 verbose stack at Process.ChildProcess._handle.onexit (internal/child_process.js:222:5)
15 verbose pkgid silhouette-play-react-seed@4.0.0
16 verbose cwd /var/www/html/mejorcambio/app-ui
17 error Linux 4.10.0-26-generic
18 error argv “/usr/bin/nodejs” “/usr/bin/npm” “–loglevel verbose” “run” "start"
19 error node v4.7.2
20 error npm v3.5.2
21 error code ELIFECYCLE
22 error silhouette-play-react-seed@4.0.0 start: neutrino start
22 error Exit status 1
23 error Failed at the silhouette-play-react-seed@4.0.0 start script ‘neutrino start’.
23 error Make sure you have the latest version of node.js and npm installed.
23 error If you do, this is most likely a problem with the silhouette-play-react-seed package,
23 error not with npm itself.
23 error Tell the author that this fails on your system:
23 error neutrino start
23 error You can get information on how to open an issue for this project with:
23 error npm bugs silhouette-play-react-seed
23 error Or if that isn’t available, you can get their info via:
23 error npm owner ls silhouette-play-react-seed
23 error There is likely additional logging output above.
24 verbose exit [ 1, true ]


#4

0 info it worked if it ends with ok
1 verbose cli [ ‘/usr/bin/nodejs’,
1 verbose cli ‘/usr/bin/npm’,
1 verbose cli ‘–loglevel verbose’,
1 verbose cli ‘run’,
1 verbose cli ‘start’ ]
2 info using npm@3.5.2
3 info using node@v4.7.2
4 verbose run-script [ ‘prestart’, ‘start’, ‘poststart’ ]
5 info lifecycle silhouette-play-react-seed@4.0.0~prestart: silhouette-play-react-seed@4.0.0
6 silly lifecycle silhouette-play-react-seed@4.0.0~prestart: no script for prestart, continuing
7 info lifecycle silhouette-play-react-seed@4.0.0~start: silhouette-play-react-seed@4.0.0
8 verbose lifecycle silhouette-play-react-seed@4.0.0~start: unsafe-perm in lifecycle true
9 verbose lifecycle silhouette-play-react-seed@4.0.0~start: PATH: /usr/share/npm/bin/node-gyp-bin:/var/www/html/mejorcambio/app-ui/node_modules/.bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/snap/bin
10 verbose lifecycle silhouette-play-react-seed@4.0.0~start: CWD: /var/www/html/mejorcambio/app-ui
11 silly lifecycle silhouette-play-react-seed@4.0.0~start: Args: [ ‘-c’, ‘neutrino start’ ]
12 silly lifecycle silhouette-play-react-seed@4.0.0~start: Returned: code: 1 signal: null
13 info lifecycle silhouette-play-react-seed@4.0.0~start: Failed to exec start script
14 verbose stack Error: silhouette-play-react-seed@4.0.0 start: neutrino start
14 verbose stack Exit status 1
14 verbose stack at EventEmitter. (/usr/share/npm/lib/utils/lifecycle.js:232:16)
14 verbose stack at emitTwo (events.js:87:13)
14 verbose stack at EventEmitter.emit (events.js:172:7)
14 verbose stack at ChildProcess. (/usr/share/npm/lib/utils/spawn.js:24:14)
14 verbose stack at emitTwo (events.js:87:13)
14 verbose stack at ChildProcess.emit (events.js:172:7)
14 verbose stack at maybeClose (internal/child_process.js:854:16)
14 verbose stack at Process.ChildProcess._handle.onexit (internal/child_process.js:222:5)
15 verbose pkgid silhouette-play-react-seed@4.0.0
16 verbose cwd /var/www/html/mejorcambio/app-ui
17 error Linux 4.10.0-26-generic
18 error argv “/usr/bin/nodejs” “/usr/bin/npm” “–loglevel verbose” “run” "start"
19 error node v4.7.2
20 error npm v3.5.2
21 error code ELIFECYCLE
22 error silhouette-play-react-seed@4.0.0 start: neutrino start
22 error Exit status 1
23 error Failed at the silhouette-play-react-seed@4.0.0 start script ‘neutrino start’.
23 error Make sure you have the latest version of node.js and npm installed.
23 error If you do, this is most likely a problem with the silhouette-play-react-seed package,
23 error not with npm itself.
23 error Tell the author that this fails on your system:
23 error neutrino start
23 error You can get information on how to open an issue for this project with:
23 error npm bugs silhouette-play-react-seed
23 error Or if that isn’t available, you can get their info via:
23 error npm owner ls silhouette-play-react-seed
23 error There is likely additional logging output above.
24 verbose exit [ 1, true ]


#5


#6

[info] :heavy_check_mark: Development server running on: http://localhost:5000
[info] :heavy_check_mark: Build completed
Now, it goes blank by putting localhost: 9000. Is this ready?


#7

What does your developer console say about JavaScript errors?


#8

Uncaught Error: Module build failed: Error: Missing binding /var/www/html/mejorcambio/app-ui/node_modules/node-sass/vendor/linux-x64-48/binding.node
Node Sass could not find a binding for your current environment: Linux 64-bit with Node.js 6.x

Found bindings for the following environments:

  • Linux 64-bit with Node.js 4.x

This usually happens because your environment has changed since running npm install.
Run npm rebuild node-sass --force to build the binding for your current environment.
at module.exports (/var/www/html/mejorcambio/app-ui/node_modules/node-sass/lib/binding.js:15:13)
at Object. (/var/www/html/mejorcambio/app-ui/node_modules/node-sass/lib/index.js:14:35)
at Module._compile (module.js:570:32)
at Object.Module._extensions…js (module.js:579:10)
at Module.load (module.js:487:32)
at tryModuleLoad (module.js:446:12)
at Function.Module._load (module.js:438:3)
at Module.require (module.js:497:17)
at require (internal/module.js:20:19)
at Object. (/var/www/html/mejorcambio/app-ui/node_modules/sass-loader/lib/loader.js:3:14)
at Module._compile (module.js:570:32)
at Object.Module._extensions…js (module.js:579:10)
at Module.load (module.js:487:32)
at tryModuleLoad (module.js:446:12)
at Function.Module._load (module.js:438:3)
at Module.require (module.js:497:17)
at require (internal/module.js:20:19)
at loadLoader (/var/www/html/mejorcambio/app-ui/node_modules/loader-runner/lib/loadLoader.js:13:17)
at iteratePitchingLoaders (/var/www/html/mejorcambio/app-ui/node_modules/loader-runner/lib/LoaderRunner.js:169:2)
at iteratePitchingLoaders (/var/www/html/mejorcambio/app-ui/node_modules/loader-runner/lib/LoaderRunner.js:165:10)
at /var/www/html/mejorcambio/app-ui/node_modules/loader-runner/lib/LoaderRunner.js:173:18
at loadLoader (/var/www/html/mejorcambio/app-ui/node_modules/loader-runner/lib/loadLoader.js:36:3)
at module.exports (/var/www/html/mejorcambio/app-ui/node_modules/node-sass/lib/binding.js:15:13)
at Object. (/var/www/html/mejorcambio/app-ui/node_modules/node-sass/lib/index.js:14:35)
at Module._compile (module.js:570:32)
at Object.Module._extensions…js (module.js:579:10)
at Module.load (module.js:487:32)
at tryModuleLoad (module.js:446:12)
at Function.Module._load (module.js:438:3)
at Module.require (module.js:497:17)
at require (internal/module.js:20:19)
at Object. (/var/www/html/mejorcambio/app-ui/node_modules/sass-loader/lib/loader.js:3:14)
at Module._compile (module.js:570:32)
at Object.Module._extensions…js (module.js:579:10)
at Module.load (module.js:487:32)
at tryModuleLoad (module.js:446:12)
at Function.Module._load (module.js:438:3)
at Module.require (module.js:497:17)
at require (internal/module.js:20:19)
at loadLoader (/var/www/html/mejorcambio/app-ui/node_modules/loader-runner/lib/loadLoader.js:13:17)
at iteratePitchingLoaders (/var/www/html/mejorcambio/app-ui/node_modules/loader-runner/lib/LoaderRunner.js:169:2)
at iteratePitchingLoaders (/var/www/html/mejorcambio/app-ui/node_modules/loader-runner/lib/LoaderRunner.js:165:10)
at /var/www/html/mejorcambio/app-ui/node_modules/loader-runner/lib/LoaderRunner.js:173:18
at loadLoader (/var/www/html/mejorcambio/app-ui/node_modules/loader-runner/lib/loadLoader.js:36:3)
at Object…/node_modules/css-loader/index.js?{“minimize”:false}!./node_modules/postcss-loader/lib/index.js!./node_modules/sass-loader/lib/loader.js?{“sourceMap”:false,“includePaths”:[“node_modules”,"/var/www/html/mejorcambio/app-ui/node_modules","/var/www/html/mejorcambio/app-ui/node_modules/neutrino-preset-web/node_modules","/var/www/html/mejorcambio/app-ui/node_modules/neutrino-preset-react/node_modules","/var/www/html/mejorcambio/app-ui/src"]}!./src/styles/core.scss (http://localhost:5000/index.js:302:7)
at webpack_require (http://localhost:5000/runtime.js:694:30)
at fn (http://localhost:5000/runtime.js:115:20)
at Object…/src/styles/core.scss (http://localhost:5000/index.js:23082:15)
at webpack_require (http://localhost:5000/runtime.js:694:30)
at fn (http://localhost:5000/runtime.js:115:20)
at Object. (http://localhost:5000/index.js:19663:127)
at Object…/src/index.js (http://localhost:5000/index.js:19753:30)
at webpack_require (http://localhost:5000/runtime.js:694:30)
at fn (http://localhost:5000/runtime.js:115:20)


#9

I already fixed this by putting: rebuild node-sass --force
Thanks for the kind support, I’m new.